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Session 10: Introduction to QGIS (interface, main functionalities)

Navigating the Interface:

Desktop

(2 Untitled Project - QGIS

Project Edit View Layer Settings Plugins Vector Raster Database Web Processing Help
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M Layers Browser
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) Type to locate (Ctrl+K) Read cordinat| 103.553,13.487 | a|1:1761401 v | @ ag?@/n 2| otatio |0.0° 2| V/Render @ epsciazze @ 2}(

QGIS interface is divided into 5 main areas:

Layers List / Browser Panel
Toolbars

Map canvas

Status bar

Side Toolbar

vk R
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Manage Layers Toolbars

VR LABRY @ @%-Vi-

e Add Vector Layer
e Add Raster Layer

e Add Delimited Text Layer

e Add Spatialite Layer

e Add/Edit Virtual Layer
e Add PostGIS Layers

e Add WMS/WMTS Layer
e Add WCS Layer

e Add WFS Layer

e New Shapefile Layer

Tropical Health Network

Map Navigation Toolbars
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Pan Map

Pan Map to Selection
Zoom In

Zoom Out

Zoom to Native Resolution
Zoom Full

Zoom to Selection

Zoom to Layer

Zoom Last

Zoom Next

New Map View
New Bookmark
Show Bookmarks

Refresh



LONDON

R aED) () HEALT MORU
HYGIENE ‘I, GEOL AR
ﬁlﬁ%}fgﬁ% (C COLLABORATIVE Tropical Health Network
Attributes Toolbar
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e |dentify Features

e Run Feature Action

e Select Features by area or single click
e Select Features by Value

e Deselect Features from All Layers

e Open Attribute Table

e Open Field Calculator

e Toolbox

e Open statistical summary
e Measure Line

e Show Map Tips

e Text Annotations
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Saving Project Files

(2 *Untitled Project - QGIS - m] X
Edit View Layer Settings Plugins Vector Raster Database Web Processing Help
1 = e W
ﬁ:from Template T » 'O ,D ﬁ) @ 'O . @ = % Q{a . \/; . // “’j ‘ : /s > ” P> n
Open.. a0 PTam- 0 NHPLLAHNPPRALERDRS
Open From >
Open Recent »
Close
S Save Ctrl+S
[ SaveAs... W Ctrl+Shift+S
Save To »
Revert...
Properties... Ctrl+Shift+P
Snapping Options... (@ Choose a QGIS project file X
Import/Export ' 4 || « EXERCISE5B.QGIS » Data v| ] | Search Date )
! i New Print Layout... Ctrl+P
21 New Report.. Organize v New folder . = - ®
% Layout Manager... B This pC A Name Date modified Type
Layouts » P 3D Objects Kampong-Cham 14/06/2018 :39 AM  File folder
Exit QGIS Ctr+Q I Desktop
|Z Documents
¥ Downloads
D Music S 5
Layers Browser File name "
Q. Type tolocate (Ctrl+K) Read oordnat| 105.050,11.723 | | 116323 Save as type: | QGZ files (*.qgz) v

Q qqz
QGIS files (*.qgs)
~ Hide Folders T T

e QGIS can save user sessions. (A QGIS file is called a project.)
e Project > Save
e Typein afile name and save your project as a QGZ file (.qgz)

o QGZ file format is a new default format for QGIS. It is a compressed
format with the .qgs file (former default format) embedded in it
together with its associated sqlite database (.qgd) for auxiliary data.
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Browser Tab

Right Click in Toolbar area to add browser
«as0ima OF Other panels to the Desktop —_
Project  Edit  View Layer Settngs Plgim  Vector Raster DOatabase Web  Processing  Help
DEER IR OBDRALsNPOLALAC HY @ -f.“u"-ls BEY=-0 3 @

= g sy o W Sd e p) i

R T Y- R LT LY Y B & ok
[~} ) ] . y & cadtll PR -~ Advanced Digiuzing L
v. Browser BE @ v Hrowser
o o < f 10 Browser (2)
] - L GPS Information
i @8 Home SRR
ol o W o Drag and Drop Wecary ks
o 7 Layer oioer
% B onto Canvas A
£, |2 % pocls > ° Log Messages
= 1l ) :r‘:;au: Overvien
R S wis Spatial Bookmarks
0 wes Statistics
@ 4 ® wWas Tile scals
Undo/Rodo
Q User nput
Yé < Advarced Dwgitaing
v Attrbutes
,u Database
V Digitizing
-
Q Flie

Help
v Label

Manage Layars
< Map Navigation
v Pugns

\P

Raster

Roctangles, ouzks digitizing todls
< Vactar
< Wieb

g&omv | layers |

& Coordinate 711639,2419515 Scale [1:2172,006

@ ersceansior) @

‘e Browser Tab From the Manage Layers Toolbar and the Browser Panel you
can add Shapefiles, Databases, WFS, WMS, and several
other types of files.
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Project Properties

Q *Untitled Project - QGIS
Edt Yew Layer Setngs Plugins Vecos Faster Datsbase Web
New CtrieN
'a ,a %z 3&1 .a 2
New from Template »
QOpen... Ctrie0 r z oo T~ 2 S
() Project Properties | General
Open From ’ - v
Open Recent ’ l ®
Close
‘ lection color; Project home; M nits; Precision
—ren e ;\ A < Selection color; Project home; Map Units; Precisio
[ savess.. CtrieShift+S Information about the project
Save To ’
Revert On The Fly reprojection
—y
Snapping Options... Assign Default symbols and set transparencies
Import/Export A ¥ Default Styles
IS N e P T
g v Priok Layoct, 5 Layer Capabilities
&) New Report... i Data Sources
< Layout Manager... . .
e A . Define 1:n relations
ES Relations
Exit QGIS Cird+Q
Manage project-level variables
Variables
Edit Python Macros
{,@ Macros
Layers | Browser Configure project in order to publish it online
X Type 1oXocate (CUral Read oodnat| 105.067,1.725 |9 sl 1:632 QGIS Server

Project Properties changes the default project setting for the CURRENT QGIS
project.
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Panels and Toolbars
Panels and Toolbars: ¥ Panels on top...
e Turn them on and off by C———
going to View > Panels or =
Toolbars. G
. - . ' B
e Panels provide interactive w |
“windows”. Examples: %
Layers,GPS Information, =
and toolbox - : v
e Toolbars are a grouping of g Py
tools 2 “f‘"”““f I.;.;:w
e Panels/Toolbars can also be = = - e
angd/removed by right- o o B
clicking on the toolbar area ——
Mo s &G @

...Toolbars
on bottom
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Vector Layer Properties

@ “Untitled Project - QGIS
Project Edit View Layer Settings Plugins Vector Raster Database Web Progessin (@ Layer Properties - COM_Kampong-Cham | Information
=Sl Bl | = o7
0 BRRY ELZRS- -@-
= I

Read-only summary of information and metadataon the current layer

Used to define general settings for the vector layer

A8 source

Provides a comprehensive tool for rendering and symbolizing vector data

¥~ symbology

1 5 Zoom to Layer Provides the capabilities to configure smart labeling on vector layers

@ 5. Zoom to Selec
=

€3 Labels
ctio .
o0 5n - - Allows to add a graphic overlay to a vector layer
2 Show in Overview .| Diagrams
Show Feature Count 2 Enables 3D rendering
Ng 3D View
Copy Layer
e rovides informati ieldsrel hi r
% e ﬁ R Provides information on fields related to the laye
= 3 Dplicate Layer Helps set up the form to display when creating new features
B8] Attributes Form

[d Remove Layer...

™ QOpen Attribute Table Allows to join a loaded attribute table to a loaded vector layer

Joins
J Toggle Editing

il E-I Aaiiary Storsge Allows to store properties for layers that are not editable
Set Layer Scale Visibility... @ Actions Provides the ability to perform an action based on the attributes of a feature
Set CRS » 0 =
Export > ® oy Helps configure fields to use for feature identification
Styles » . isibili P
m & Fendeing Allows to set the scale dependent visibility and simplify geometry
Layers | Browser ' Vbl Lists all the variables available at the layer’s level

Type to locate (Ctrl+¥ dnat| 103.488,12.069 W i n: - : . .
E fendie % alluiseen B vesde Provides options to create and edit a metadata report on a layer

Allows to declare data dependencies between layers
T Dependencies

Provides advanced settings for the Layers panel and/or the print layout legend

Legend

R Consists of Description, Attribution, MetadataURL, and LegendUrl sections

Gives access to options that help to ensure the quality of digitized geometries
B oigitizing

The (Vector) Layer Properties window provides information about the vector layer
and provides general settings to manage appearance of layer features in the map
(symbology, labeling, diagrams) and interaction with the mouse (actions, map
tips, form design).
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Data Projections

@ *Untitled Project - QGIS
Project Edit View Layer Settings Plugins Vector Raster Database Web Progessing

D DB}:: v;'c,uﬂ:@.u'@'@
Q/)rﬁ"';@ﬁ@'ﬁzﬁ'o s (’j;

Layers B®
a5 e b
ROV E-FAO
9 O oomto Lyer @ Laye: Propestiés - COM. Kampong:Cham | Source X
5 Zoom to Selection 4 w Settings
=5 8 Show in Overview = Layer name |COM_Kampong-Cham dsplayed as |COM_Kampang-Cham
Show Feature Count
abe| Data source encoding | System
» Copy Layer
5 Rename Layer v Geometry and Coordinate Reference System
.‘,h L] Duplicate Layer Set source coordinate reference system
1 Remove Layer... EPSG:4326 - WGS 84 L IE
s
™! Open Attribute Table "\ Diagrams Create Spatial Index | |Update Extents &
J Toggle Editing
NN
Filter... Ny 30 View w Provider Feature Filter
Set Layer Scale Visibility... ﬁ Source Fields
Set CRS
B Attributes Form
Styles » Joins
Layers | Browser ! n Auwxiliary Storage
Read oordnat| 103.488,12.069 |V al|1:159984 v | & (Q Actions
Query Buider
B oispioy
Style - oK Cancel Apply Help

All vector/raster layers have a projection or CRS. The quickest way to check
projections is to right click on the layer > Properties > Sources
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Raster Layer Properties

@ *Untitled Project - QGIS

2017
- v [1] cOM_Kampong

B
B

Layers | Browser

Project Edit View Layer Settings Plugins Vector

DEERBRE

% 3 o1

Raster Database Web Progessi

v;'n,a»/om's'@'
L EEX=-PO- [

e

£ Zoom to Layer
©2 Show in Overview
Copy Layer
Rename Layer
S Zoom to Native Resolution (100%)
Stretch Using Current Extent
L] Duplicate Layer
"1 Remove Layer...
Set Layer Scale Visibility...
Set CRS »
Export »

Styles »

Properties...

1legend entries removed. Coordinate | 104.471,12.41

APMEN

asia pocific mokoria eliminafion networ

MORU :::
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¥ symbology

I_ﬂ Transparency
B8 Histogram

& Rendering
@R Pyramids

l Metadata
-

Legend

QGIS Server

Q Layer Properties - mgy_srtm_90 | Source X

Read-only summary of information and metadataon the current layer

Displays basicinformationaboutthe selected raster

Allows to change to the band and color rendering and raster resampling

Allows to set the transparency level of the raster layer

Allows to view the distribution of the bands or colors in the raster

Allows to set scale dependent visibility and refresh layers at interval

Allows to build pyramids to improve raster performance

Provides options to create and edit a metadata report on a layer

Provides a list of widgets that can be embedded in the Layers panel

Consists of Description, Attribution, MetadataURL, and LegendUr| sections

The (Raster) Layer Properties window provides information about the layer as
well as the ability to set pyramids levels, adjust appearance, and view the

histogram.
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Layout Manager

(Q Untitled Project - QGIS
Edit View Layer Settings Plugms Ve<tgr

New Ctrl+N
3
New from Template »

QOpen... Ctrl+0 3 z

Open From »

4 Layout Manager - m] X
eCce -
Open Recent » l—j New
Close D Print Layout
[ Save Ctrl+S
3 SaveAs.. Ctrl+Shift+S

Save To » = —
=hov Dupicate

w New from Template

Revert...

Properties... Ctrl+Shift+P
Snapping Options... Empty layout v || Create.
Import/Export » NCOUNTRIES \KHMMap_Template \KHM_MOH_Landscape _11052018.qgpt

I’} New Print Layout... Ctrl+P Open template directory User Default
¢} New Report... pl

% Create print layout Title X
= =

Layouts » Enter a unique print layout title
Bxit QGIS ol | (a title will be automatically generated if left empty)

L | oK Cancel

The Layout Manager allows you to create a new map layout either from an empty
layout or a template. It can be accessed from the Project menu (Project > Layout
Manager) or in the Print Layout window (Layout > Layout Manager).
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Print Layout

Q "New g - 3 X
Layout Edit View Items Addheas Settings -

[I.E&L@D’:@% by Uy ® @ K‘"i T r L

@ﬁ@ﬂu %E@QIQE—‘I:U'B[L

A

B FBAPENBEBS |

AT

1sa| )

[ R

|5

i 1item selected

BB M Kampongiam

J....P....l....F?... |‘°° ' Ilso..|,...P?o...l....F?o...l.u.quj.. Items | Undo History

| 3 Items @®
[ [e- © @ lem /
| . v = <Picture>

| = MAP TITLE v w= <Scalebar> h

{ . Rinsd v & Legend

s 3 mgy_stm 90 v [T] MAP TITLE

| e -o

| R =i v 1 Map1

.Layout Item Properties a:ds.
emPropems .@ o®

w Main Properties

Update Preview

x: 310.903 mm

Scale 546475 €

Map rotation |0.00 ® €

CRS Use project CRS - %

vV Draw map canvas items -
y: 98,3803 mm page: 1 48.7% v | CE

Print Layout interface: 1. Menu Bar; 2. Toolbar; 3. Map Layout; 4. Items and
Command History; 5. Layout Properties; 6. Item Properties; 7. Guides
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Layout Toolbar Navigation Toolbar
BERREDB L eBkEkhee 2080
e Save project e Zoomin

e New layout Zoom out

e Duplicate layout Zoom to 100%

e Layout manager Zoom full

e Add items from template Refresh view

e Save as template
e Add Pages...

e Print Layout

e Export asimage
e Exportas SVG...
e Export as PDF...
e Undo

e Redo
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Print Layout

> Click on the Add Map button then draw a rectangle
for where the Map Canvas will appear.

@ *Print Layout - [m] X
Layout Edit View [tems Additem Atlas Settings
BERORER R eRRkoe @lee: +A0un
LPLAAT RO K EE bE]
J.ynP....l...'}sq”.l...yx?o..u....Ils.o..-l....P?O...l|..VF§OV..|H.1.P‘?°..' Items  Undo History
@ Items 8%
pc'— ® @ |[ltem
N 3 - =] = v 1 Map1
CIE
> B
—-— ‘ré =
& - Layout | ItemProperties | Guides
8- ) O Item Properties @x
= Map1
| = v Main Properties 3
i‘cgf Update Preview
=2 —E Scale 429806 a
““a I Map rotation | 0,00 Q=
/:}g— - H - ®s Use project GRS -
o V' Draw map canvas items
¥ 3 -
1 item selected X: 291.336 mm y: 100,554 mm page: 1 48.7% v|¢
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Map Elements

Add map elements by clicking on the icons on

APMEN
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This area keeps track of changes

and allows you to customize map <€
the toolbar or in the Add Item menu elements.
|
Q *New - m] K
Layout Edit View lte m ftlas  Settings
BLEROE B @ik e & | | & 8 &
LLANR BB E L EE A
(s P e s e 0 S 0 e e P e R s O s [
@ 3 ftems B
HOIEE & @ Item
s 3 T MAP v r= <Picture> [}
I ] ! E TITLE v «= <Scalebar> -
3 tagend v 3= Legend
| : e v T] MAP TITLE
R o v e
E B0 oM xanpong v
e ¥ o Q o Layout | ItemProperties | Guides
rn B- — 3 ==
- Item Properties 2
- - Map1
f: w Main Properties =
N : Update Preview
“a( 3
; = Scale 546475 (=8
:: : as 1 Map rotation | 0.00 * S
2 ; RS Use project CRS
3 - V| Draw map canvas items -
1 item selected x: 310,903 mm y: 98.3803 mm page: 1 48.7% v |

Once the map has been added, the other map elements can be added. Their
properties, as well as the page properties, can be viewed and modified. The Print
Layout tracks changes in the Undo History window.

Layout

e Set the grid spacing and snap
tolerance

e Export settings

e Resize layout to content

Item Properties

Set the font
Set scale bar properties
Set legend properties

Set map element properties




