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BACKGROUND 

The Need for the Tool and the Logic Behind It 

Data are essential to a well-functioning health system. An explosion in the quantity of data available has 

prompted an increasing emphasis on how this information can be used to advance global health. Within this 

burgeoning “data tsunami,” as some have called it, are rich streams of data on the populations at risk and in 

need of treatment for HIV and other diseases, the services being provided, and the context in which these 

both exist. Many of these data streams have a geographic component. We know more about “where things 

are” than ever before. Knowing where a health clinic or dispensary is located can be useful in making 

decisions about how best to provide public 

health services for a certain size or type of 

population or how to handle referrals from 

nearby facilities.   

The amount of data it is now possible to 

comprehend within a health information 

system presents both a challenge and an 

opportunity to improve health and health 

services in low- and middle-income 

countries. MEASURE Evaluation, funded 

by the United States Agency for 

International Development (USAID), 

takes a holistic view of health information 

systems. That means we help countries 

improve and digitize their health 

information, but we also help build human 

capacity to understand and manage the 

rich data now available. Spatial data is an 

important part of this holistic view. 

These kinds of geographic data coordinates are easier than ever to collect, by using a smartphone, tablet, or 

Global Positioning System (GPS) receiver. When the coordinates are stored in a table or spreadsheet, they 

can be shown on a map.   

One way to ensure that the coordinates are accurate is to plot the locations in a geographic information 

system (GIS) and then carefully examine the attribute data associated with the points. The data table can be 

quite large, involving many hundreds or thousands of points. Reviewing each point location for accuracy and 

correctness in such a large database can be time-consuming, tedious, and challenging because of the complex 

relationship between the spatial characteristics and the associated attributes of the data points. Ensuring 

geographic data quality typically requires the skills of an experienced GIS technician. 

The Spatial Quality and Anomalies Diagnosis (SQUAD) tool provides a framework for assessing the overall 

quality of a spatial database and can be run by someone with minimal GIS experience. The tool provides a 

consistent, clear assessment of potential problems with a given spatial database. After potential anomalies 

The Value of This Manual  

Why useful: Large spatial data sets can be used to locate 

disease hot spots or health facilities where services are 

needed. However, these data can be difficult to check for 

quality without a time-consuming examination by a trained 

GIS technician. This new tool—called the Spatial Quality 

and Anomalies Diagnosis (SQUAD) Tool 

(https://www.measureevaluation.org/resources/tools/ 

geographic-information-systems/squad-tool)—can help  

a GIS novice identify potential errors in a location-based 

data set (such as a master facility list) in a short period. This 

document proposes data correction strategies, based on 

the tool’s output. 

Advantage of QGIS version: Traditionally, the use of a full-

featured GIS requires an expensive license. However, the 

blooming of open-source software has brought with it a full-

featured GIS software that is free and open-source, called 

QGIS. The SQUAD tool is now available as a QGIS plug-in. 

This document shows how to get the software and how to 

install the plug-in. 

 

https://www.measureevaluation.org/resources/tools/%0bgeographic-information-systems/squad-tool
https://www.measureevaluation.org/resources/tools/%0bgeographic-information-systems/squad-tool
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have been identified, the records in question can then be examined in detail, and the errors can be corrected. 

This tool offers a clear picture of the extent and type of the problems that might be associated with a given 

geographic data set, enabling solutions for improving the data to be prioritized.  

The tool checks for six anomalies that are based on common errors in point-location data sets. This 

information can be used to prioritize the type and extent of investigation needed for records that may have 

problems. The tool checks for the following anomalies: 

1. Missing coordinates 

2. Truncated coordinates (lack of adequate precision) 

3. Duplicate coordinates for distinct records 

4. Duplicate key attributes (two identical names, but plotting in different locations) 

5. Coordinate not located exactly where it would be expected (but falling within two kilometers of a 

border) 

6. Coordinate not located anywhere near where expected 

The presence of some anomalies may not mean that there are errors. For example, two different sites in two 

different districts could have the same name but would be reported as an anomaly. These kinds of anomalies 

merit examination to ensure that they are not errors. 

Although additional data quality assessment will likely be required, this framework is a starting point for 

examining a large data set in an efficient manner. If these errors are identified early, the data set can be 

corrected and made stronger, more useful, and more trustworthy. 

The sections that follow describe a practice session with the tool. 

Scenario 

Your health ministry has done extensive data collection to locate every health facility in the country. The data, 

in the form of facility names, districts, and GPS coordinates, must now be checked for quality assurance.   

You need a quick but systematic way to determine whether each facility is located in its expected location on 

the country district map, and if not, why not. By getting a look at the scope of potential problems in this new 

data set, you can plan how to fix them. A high-quality data set will boost confidence and ensure maximum 

utility in the future. 

What You Will Need 

The SQUAD tool is available as a plug-in for QGIS that runs using the data in question. It requires QGIS 

version 2.18 or 3.0, which is available for free use and distribution without license from www.qgis.org.  The 

facility point file (containing the facility’s X and Y coordinates and attributes) and the associated 

administrative unit file (with names and outlines of districts or regions) must both be stored as shapefiles. 

These commonly used GIS files store both geometry information (points, lines, and area locations) and 

attribute information (names and other characteristics of things at each location). See Appendix A for what 

to do if your X and Y coordinates are stored in a spreadsheet and need to be plotted to a point file. 

http://www.qgis.org/
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These files can be stored either in WGS84 (World Geodetic System 1984) unprojected format or in an 

appropriate UTM (Universal Transverse Mercator) projection (so that measurements can be made in meters). 

More information about coordinates and projections is available in Appendix B. 

The following are required for each shapefile’s attribute data table: 

• Facility (point) shapefile should include the following: 

• Unique ID: a unique identifier for a facility 

• Separate fields for the X (longitude) and Y (latitude) coordinates of the site (in decimal 

degrees) 

• Site name: name of the site or facility 

• Admin: name of the administrative unit where the site is located 

• District (polygon) shapefile should include the following: 

• A field with a name for the administrative unit (such as a district name) 

• An ID field for each administrative unit 

To go through the tutorial described in the SQUAD Tool Tutorial Section, you will need to download the 

sample data provided on the MEASURE Evaluation website with the QGIS Quick Start Guide. The data 

contain two shapefiles: one representing all the facility point locations and another that contains the 

boundaries and names for all associated districts in a theoretical country (available at 

https://www.measureevaluation.org/resources/tools/geographic-information-systems/squad-

tool/qgis%20sample%20data%20package.zip or use http://bit.ly/sampleSQUAD).  

https://www.measureevaluation.org/resources/tools/geographic-information-systems/squad-tool/qgis%20sample%20data%20package.zip
https://www.measureevaluation.org/resources/publications/ms-18-132/
https://www.measureevaluation.org/resources/tools/geographic-information-systems/squad-tool/qgis%20sample%20data%20package.zip
https://www.measureevaluation.org/resources/tools/geographic-information-systems/squad-tool/qgis%20sample%20data%20package.zip
http://bit.ly/sampleSQUAD


4           SQUAD Tool for QGIS 

SQUAD TOOL TUTORIAL 

Setting up a Project File in QGIS  

NOTE: Screen shots are for QGIS version 2.18. The interface of version 3.0 may have a slightly different 

appearance, but the steps are basically the same. 

Step 1 

Copy the sample data file to the location of your choice.   

 

Double-click on the file and choose Extract all.   

Step 2 

Launch QGIS by clicking on the QGIS Desktop shortcut icon or by searching for the app in the windows 

taskbar and clicking on it.   

 

 

 

 

Open a new project by selecting Project>New.  

Step 3 

In the Browser Panel, navigate to your sample data folder. 

NOTE: If you do not see a Browser Panel, choose 

View>Panels>Browser Panel. 

 

Double-click on the Demoland_Districts.shp file and the Demoland_facilities.shp file to load them in 

the main view panel. The file names will appear in the Layers Panel. 

NOTE: Colors will be chosen automatically. To customize the colors, double-click on each symbol in the 

Layers Panel to open the Layer Properties box. Select the Style or Symbology tab and change the fill color. If 

the facilities file was loaded first, drag the file name to the top of the Layers Panel to see it on the map. 
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Your screen should look like the following:  

NOTE: If you do not see these Panels, go to View>Panels>. 

If you would like to Save the file and come back to it, you may now do so. The saved file will have the 

extension “.qps,” which stands for “QGIS project file.”  

NOTE: A “project file” is a reference to a set of GIS data files, such as shapefiles, and serves as a work place 

where you can view the data files and assign them various styles.  The Demoland_Districts file is symbolized 

by polygons because it represents areas. The Demoland_facilities file is symbolized by points because it 

represents discrete locations. The data do not reside in the project file; they reside in the shapefiles. If 

you want to share a project file, you should also share the shapefiles that it references.  

Installing and Running the Plug-In 

Go to Plugins>Manage and Install Plugins… 

In the Search bar, type “SQUAD” and type “Enter.” In the results box, you should see “SQUAD Tool” (for 

version 3.0, look for “SQUAD Tool v3”). Check the box next to it, and then click on the “Install plugin” 

button in the lower right. 
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Close the dialog box, and the tool’s icon will appear in your toolbar.   

You can also access the installed tool via Plugins>SQUAD>SQUAD Plugin. 

Familiarizing Yourself with the Data 

Step 1 

Right-click on the Demoland_facilities layer in the Layers Panel and select “Open Attribute Table.” This will 

open a table listing the fields that house the attribute data associated with these data points.   

 

The fields are described as follows: 

• Name is the name of each facility.   

• Region, Country, and District help indicate the position of each facility. In this example, the 

SQUAD tool will determine whether the District records are correct.  

• POINT_X is the longitude coordinate in decimal degrees. (It is negative because it is located west of 

the prime meridian.)  

• POINT_Y is the latitude coordinate in decimal degrees. (It is positive because it is located north of 

the equator.)  

• UID is a unique ID field for each facility.   
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Step 2 

Right-click on the Demoland_Districts layer in the Layers Panel and select “Open Attribute Table.” This 

will open a table with the records  of the attribute data associated with these areas. 

 

 

 

 

 

 

 

In this table, the important field to note is the following:  

• Dist_name: Each district on the map must have a unique name.  (NOTE:  If this is not the case, 

then the table needs to be edited as such, i.e. Bird1 and Bird2, or Animal_Bird and Food_Bird). 

Running the Tool 

Step 1 

Click on the SQUAD tool icon to activate the tool. The following dialog box will appear: 
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Step 2 

Select the parameters needed to check for anomalies in the data set. For the Demoland test data set, choose 

the following parameters: 
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Explanation of Parameters 

“Site File” is the facilities (point) file. 

“Site Admin Unit Field” is the field that identifies the administrative unit to check for the facilities. In this 

example, “District” is the administrative unit. 

The “Site Longitude Field” and “Site Latitude Field” show the coordinates in the facilities file. NOTE: These 

must occur in the “decimal degrees” format. 

The “Site Name Field” displays the name of each facility, and the “Site ID Field” contains an ID for each 

facility. 

The “Administrative Units File” contains the district polygons. 

The “Admin Unit Name Field” contains the names of the administrative units to use for comparison with the 

field used in the facilities file. NOTE: These names must use the same spelling conventions as the names 

used for the “Site Admin Unit Field.” 

Step 3 

Click on the three dots beside the “Site Anomalies Output” box and select “Save to file…” to choose a 

name and location for your output file. Keep the “Open output file after running algorithm” box checked. 
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Step 4 

Review your entries, and then click on the Run button. The progress bar at the bottom will show you the 

progress as the program runs. The demonstration file is small, so the program should run quickly. 

Observing the Results 

Step 1 

Open the Site Anomalies Output attribute table. (Hint: Right-click on its name in the Layers Panel to find 

the correct command.) The tool has added six new fields to the table. 

Step 2 

Click on the title bar of the Anomaly_1 field a few times to sort it. When the table has been sorted based on 

that field, all the 1s will appear at the top of the table. 

 

Look at each of these records. For the “Cardinal” facility, the POINT_X field is zero. For the “Ravioli” 

facility, both the POINT_X and POINT_Y fields are zero, (displayed here as “0.000000000”—depending on 

your settings, you may see <NULL> in these fields, or the fields may be blank. Anomaly_1 is the field for 

missing coordinates. These missing items need to be reviewed. 

Step 3 

Click on the rest of the anomaly title bars, sorting them to bring the entries coded with a “1” to the top. Can 

you determine what the problems might be for these records? (Remember, Anomaly 2 indicates truncated 

coordinates, Anomaly 3 indicates duplicate locations, and Anomaly 4 indicates duplicate facility names.) 
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Step 4 

Anomalies 5 and 6 both apply to locations (according to the given coordinates) not falling into their expected 

districts.   

To examine Anomaly 5 on the map, click on the field name and sort it. Then click on the small box to the 

left of the record with a “1” code in the table to select (highlight) that record. 

 

Drag the table to the side of the map underneath to see that point highlighted on the map. 

 

Do this for the points that have 1s marked for Anomaly 5 and for Anomaly 6. What is the difference? 

(Hint: The Anomaly 5 point is very close to a border.) What do you think is wrong with the Anomaly 6 

points? (Hint: To determine whether a point is falling in the correct district, try labeling the districts with 

their names. To do this, right-click on Demoland_Districts in the Layers Panel and then select Properties. 

Then select the “Labels” tab. At the top of the box, select “Show labels for this layer” and Label with 

“Dist_name” and click on OK. Highlight the “Pear” facility in the Health_facilities attribute table. In which 

district should it supposedly be? Do you see the possible error?)  
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Step 5 (optional) 

Save the table with the anomalies to Excel.   

There are two options for saving the output to Excel: 

1. If you have already chosen to output to a shapefile, right-click on “Site Anomalies Output” in the 

Layers Panel and then choose “Save As…” Under Format, choose “Comma Separated Value (CSV)” 

and enter a file name/location using the Browse button, and then click on Save. You can then go to 

your desktop and open this file in Excel. 

 

 

 

 

 

2. If you would like to run a new file, click on the SQUAD tool button. Fill out the appropriate 

parameters. Under “Site Anomalies Output,” click on the browse button. Choose “Save File 

As…” and then in the dialog box, under “Files of type,” select “XLSX files,” and run the 

tool. The output will appear in the Layers Panel. 
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DATA CORRECTION PROCESS 

When you begin the data correction process, here are some suggestions for handling the different types of 

anomalies. 

Anomaly 1. Missing coordinates 

• Review the data collection sheet, if available, and determine whether records were omitted. 

• Obtain the actual coordinates of a facility using a handheld GPS receiver or mobile phone. For more 

information on GPS data collection, see the following resources:  

• MEASURE Evaluation’s mini-tutorials (5- to 10-minute videos) can help beginners collect 

GPS coordinates, download the data to a computer, and carry out other basic GIS tasks: 

https://www.measureevaluation.org/resources/training/online-courses-and-resources/non-

certificate-courses-and-mini-tutorials/gis-step-by-step-tutorials/. 

• MEASURE Evaluation also offers information on collecting data using a GPS receiver: 

https://www.measureevaluation.org/resources/training/capacity-building-

resources/geographic-information-systems-mapping-and-analysis-of-spatial-data/tools-

tips/FS1383_GPScoordinates_Dec2013.pdf/view. 

• Obtain the coordinates through a visual examination in Google Maps or Google Earth. For example, 

a cursor placed over a known nearby road intersection will display the coordinates in the lower right-

hand corner of the screen. More information on using Google Maps to search locations is available at 

http://support.google.com/maps/answer/3092445. 

Anomaly 2. Truncated coordinates (lack of adequate precision) 

• Review the data collection sheet, if available, and determine whether records were incorrectly 

transferred or whether digits were left off or rounded. 

• Obtain the actual coordinates of a facility using a handheld GPS receiver or mobile phone (see 

resource links above). 

• Obtain the coordinates through a visual examination in Google Maps or Google Earth. For example, 

a cursor placed over a known nearby road intersection will display the coordinates in the lower right-

hand corner of the screen (see resource the link above). 

Anomaly 3. Duplicate coordinates for distinct records 

• Determine whether the anomaly is really an error. It could be correct, such as in the case of a 

dispensary located at the same address as a hospital. 

https://www.measureevaluation.org/resources/training/online-courses-and-resources/non-certificate-courses-and-mini-tutorials/gis-step-by-step-tutorials/
https://www.measureevaluation.org/resources/training/online-courses-and-resources/non-certificate-courses-and-mini-tutorials/gis-step-by-step-tutorials/
https://www.measureevaluation.org/resources/training/capacity-building-resources/geographic-information-systems-mapping-and-analysis-of-spatial-data/tools-tips/FS1383_GPScoordinates_Dec2013.pdf/view
https://www.measureevaluation.org/resources/training/capacity-building-resources/geographic-information-systems-mapping-and-analysis-of-spatial-data/tools-tips/FS1383_GPScoordinates_Dec2013.pdf/view
https://www.measureevaluation.org/resources/training/capacity-building-resources/geographic-information-systems-mapping-and-analysis-of-spatial-data/tools-tips/FS1383_GPScoordinates_Dec2013.pdf/view
http://support.google.com/maps/answer/3092445
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Anomaly 4. Duplicate key attributes 

• Determine whether the anomaly is really an error. It could be correct, such as in the case of two 

clinics in different parts of the country having the same name. 

Anomaly 5. Coordinate not located where expected, but falling within 
two kilometers of a border 

• Review the data collection sheet, if available, to confirm coordinates. 

• Obtain an administrative boundary file from a different source. A point falling very close to a 

boundary could indicate that the boundary itself is wrong or inaccurate. A good source is the 

Database of Global Administrative Areas: http://www.gadm.org/. 

• Validate coordinates using imagery such as Google Earth or Bing.  

• For information about adding imagery from within QGIS see 

https://gis.stackexchange.com/questions/20191/adding-basemaps-from-google-or-bing-in-

qgis (this post talks about the OpenLayers Plugin for 2.18 and the XYZ Tile Server provider 

for 3.0). 

• For information about Google Earth, see http://www.google.com/earth/. 

Anomaly 6. Coordinate not located anywhere near where expected 

• Review the data collection sheet, if available, to confirm coordinates. 

• Check the spelling of administrative units in the administrative boundary file. 

• Check to confirm that the point file has the correct administrative area designations.  

• Validate the coordinates using imagery such as Google Earth (see above), or re-collect the data using 

a GPS receiver or mobile device. 

  

http://www.gadm.org/
https://gis.stackexchange.com/questions/20191/adding-basemaps-from-google-or-bing-in-qgis
https://gis.stackexchange.com/questions/20191/adding-basemaps-from-google-or-bing-in-qgis
http://www.google.com/earth/
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CONCLUSION 

The SQUAD tool is useful for assessing the quality of a spatial database and does not require extensive GIS 

experience to run. The scenario described provides a hands-on exercise in running the tool and the types of 

potential errors that may be revealed. The anomalies provide a quick view of the scope of problems in a given 

file. Low numbers of anomalies indicate that the quality of the spatial data is good overall.  
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APPENDIX A. CREATING A POINT FILE FROM A LIST OF 
COORDINATES 

The Spatial Quality and Anomalies Diagnosis (SQUAD) tool requires all inputs to be in the form of 

shapefiles. If you are starting from a spreadsheet that lists coordinate locations, you can plot these using 

QGIS and then export the result to a shapefile that contains the geometry and attributes for all the point 

locations.  

The basic steps are as follows: 

1. Open your spreadsheet in a program such as Excel and save it as a comma-separated values (CSV) 

file. This assumes that your spreadsheet contains separate columns for the X (longitude) and Y 

(latitude) coordinate values, and that the values are in decimal degrees format, stored with a precision 

of at least five decimal places. If this is not the case, you will have to format these values in Excel or 

another program before proceeding. 

2. Open QGIS and click on the Add Delimited Text Layer button. Browse to the CSV file 

and click on Open. Under File format, choose CSV. If the first record in your table contains field 

names, check that box.  

3. Specify the Geometry definition (Point coordinates) and the X field (Longitude) and Y field 

(Latitude).  

 

NOTE: In QGIS 3.0, choosing “Layer>Add Layer>Add Delimited Text Layer…”  will take you to 

the Data Source Manager and the Delimited Text tab. From there, follow the steps above, choosing 

the CSV file format, specifying whether the first record has field names under Record and fields 

options and specifying the X and Y fields under Geometry definition. 

4. Click on OK. The points should plot on the map, and a temporary layer will appear in the Layers 

Panel. Next you will save the file as a shapefile. 
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5. Right-click on the new temporary file in the Layers Panel and choose Save As… Under Format, 

choose “ESRI Shapefile.” Browse to a location and name it, and make sure the “Add saved file to 

map” box is checked. Then click on OK.  

6. The resulting shapefile contains the X, Y locations. This file can be used with the SQUAD tool. 
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APPENDIX B. FREQUENTLY ASKED QUESTIONS ABOUT 
COORDINATE SYSTEMS AND PROJECTIONS 

What is a projection?  

There are two main ways to refer to coordinate locations on the Earth.   

“Unprojected” coordinates refer to a point on the globe (sphere). For this system, coordinates are measured 

in degrees: 0 to 90 degrees north or south of the equator is the latitude; 0 to 180 degrees east or west of the 

prime meridian is the longitude. These can be further specified as degrees, minutes, and seconds (DMS) or as 

decimal degrees (DD). There are many conversion programs online to convert from DMS to DD. 

“Projected coordinates” are projected onto a flat surface, such as a map. These are also called Cartesian 

coordinates. These are the X, Y coordinates used in algebra and on graphs. In a Universal Transverse 

Mercator (UTM) projection system, the Earth has been projected onto a flat surface and portioned into 

zones. Each zone has an origin, or 0,0 starting point, in its lower-left corner. Each set of coordinates is 

measured in meters from the zone’s origin. 

For comparison, here are illustrations of unprojected coordinates for Abuja, Nigeria (on the left) and 

projected (UTM) coordinates for the same location (on the right). 

 

A more detailed and further illustrated explanation of coordinate systems and Earth geometry can be found at 

http://kartoweb.itc.nl/geometrics/Coordinate%20systems/coordsys.html. 

 

  

http://kartoweb.itc.nl/geometrics/Coordinate%20systems/coordsys.html
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How do I determine which UTM zone to use?   

An explanation and map of zones can be found at http://www.maptools.com/tutorials/grid_zone_details or 

http://geokov.com/education/utm.aspx. 

To determine a location’s UTM zone, type in the name of the location and “UTM zone” in Google, and then 

double-check the findings with one of the above charts.   

How do I determine what projection I am working with in QGIS? 

To determine whether your data source has a defined coordinate system, right-click on the layer in the Layers 

Panel, and click on Properties to open the Layer Properties dialog box. Click on the General tab, and then 

look in the Coordinate Reference System box.  

QGIS comes with tools for defining and changing coordinate systems. For more information, see the latest 

QGIS user guide at https://docs.qgis.org/2.18/pdf/bg/QGIS-2.18-UserGuide-bg.pdf. 

  

http://www.maptools.com/tutorials/grid_zone_details
http://geokov.com/education/utm.aspx
https://docs.qgis.org/2.18/pdf/bg/QGIS-2.18-UserGuide-bg.pdf
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