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HIS Geo-enabling Course
Exercise 4.B: Using the basic functionalities of GIS software (QGIS)

Navigating the Interface:
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QGIS interface is divided into 5 main areas:
1. Main Menu
e Provides access to various QGIS features using a standard hierarchical menu
2. Layers Panel / Browser Panel
e Layers Panel: where you will see the list of different map layers you have added to

your map
e Browser Panel: Lets you easily navigate in your file system and manage your data.
3. Toolbars

e Provides access to most of the same functions as the menus, plus additional tools
for interacting with the map

4. Map View
e Also called Map canvas, this is the “business end” of QGIS — maps are displayed in
this area.

5. Status bar
e Provides you with general information about the map view, and actions processed
or available and offers you tools to manage the map view.
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Saving Project Files

() *Untitled Project — QGIS
Edit View Layer Settings Plugins Vector Ras|
New Ctrl+N - -

o)
| New from Template » =

Open... Ctrl+0

J Open From 'l@®
‘ Open Recent » (2 Choose 2 QGIS project file %

Close 2 <« EXERCISES » EXERCISE 4 v C Search EXERCISE_4 o

?
& Save Ctrl+S
Organize v New folder

H Save As... Ctrl+Shift+S -

Name

]
©

Save To »
33 Dropbox DATA

Revert... M This PC L0GO
J Properties... Ctrl+Shift+P = Windows () | MAP_TEMPLATE

w= New Volume (D:

Snapping Options...
Import/Export »

w= My Passport (E:)

w= Freefgent GoFle
o New Print Layout... Ctrl+P -

File name:

%} New Report...
R Save astype: QGZ files (*.qgz) v
« Layout Manager...

Layouts > A Hide Folders Save Cancel

Models »
Exit QGIS Ctrl+Q

e QGIS can save user sessions. (A QGIS file is called a ‘project’.)
e From the main menu, click Project > Save
e Type in afile name and save your project as a QGZ file (.qgz)

o QGZ file format is the new default format for QGIS. It is a compressed
format with the .qgs file (former default format) embedded in it
together with its associated sqlite database (.qgd) for auxiliary data.



HEALTH g MQRU_
GEOLAB Hub Epidemiology

Manage Layers Toolbar
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e Add Vector Layer

e Add Raster Layer

e Add Mesh Layer

e Add Delimited Text Layer

e Add Spatialite Layer

e Add/Edit Virtual Layer
e Add PostGIS Layers

e Add WMS/WMTS Layer
e Add WCS Layer

e Add WEFS Layer

e New Shapefile Layer
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Map Navigation Toolbar

AERPP R

Pan Map

Pan Map to Selection
Zoom In

Zoom Out

Zoom Full

Zoom to Selection

Zoom to Layer

Zoom to Native Resolution

Zoom Last

Zoom Next

New Map View

New 3D Map View

New Spatial Bookmark
Show Spatial Bookmarks
Temporal Control Panel

Refresh
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Attributes Toolbar
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e |dentify Features
e Open Field Calculator
e Toolbox

e Show Statistical Summary

e Open Attribute Table

e Measure Line

e Show Map Tips
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Browser Tab

Project  Edit  View Layer Settings  Plgim  Vector  Raster
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Right Click in Toolbar area to add browser
a0 OF Other panels to the Desktop
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From the Manage Layers Toolbar and the Browser Panel you

can add Shapefiles, Databases, WFS, WMS, and several

other types of files.

x
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Project Properties

( *Untitled Project — QGIS

Edit View Layer Settings Plugins

Vector Raster D

New
New from Template
Open...
Open From
Open Recent
Close
[ Save
[ Savess...
Save To

Revert.

Snapping Options...
Import/Export
1) New Print Layout...
¢j New Report...
4 Layout Manager...
Layouts

Models

Exit QGIS

Ctrl+N

Ctrl+0

Ctrl+S
Ctrl+Shift+S

B Propetties... Ctrl+Shift+P

Ctrl+P

Ctrl+Q

G- G
Id 4

|

'lem

»

—_—
(2 Project Properties — General

& General

!‘ Metadata

[82] view settings

& s

6“;'. Transformations

.é/ Styles
Data Sources
-. Relations

Variables

Sensors
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<——— Project file name; Project home; Map Measurements

Allows detailed metadata to be defined

Provides means to control the project map canvas

Helps set the coordinate reference system of the project
Helps control the layers reprojection settings

Allows to configure symbols and colors

Allows to configure the editing behavior & layer capabilities
Used to define relations between layers

Allows to manage project-level variables

Used to edit Python macros

Allows to configure project in order to publish it online
Used to set the temporal range of the project

Helps configure default settings for the terrain and elevation

Used to configure sensors and toggle their connection status

Project Properties allows to change the default settings for the CURRENT QGIS

project.
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Panels and Toolbars

Poject ot [ Lover Settings Blugins ecar [ster Databwse Mieb Mesh Progessing Help
AT Br/B% R8T
Panels and Toolbars: Rk 2 oind e
« Turn them on and off by going| “* " " W
to View > Panels or Toolbars — b '
* Panels provide interactive B o
“windows”. Examples: Layers, B
Browser, GPS Information 8 reemt
* Toolbars are a grouping of _ w :
tools B o resi it o
* Panels/Toolbars can also be -m

added/removed by right-
clicking on the toolbar area
then checking/unchecking the
desired panel or toolbar

Progessing Help

,u%.‘y{;‘u'

-~
[~

o
»

Toolbars

Toggle Full Scrgen Mode
Toggle Panel Visibility
Toggle Map Only

Advanced Digitizing Panel

<

Browser Panel
Fit
Cirl+Teb

Browser (2) Panel
Debugging/Development Tools Panel

Carl+Shift Tab GPS Information Panel

Panels
Advanced Digitizing Panel
Browser (2) Panel

| BrowserPanel
Debugging/Development Tools Panel
GPS Information Panel
Layer Order Panel
Layer Styiing Panel

| Layers Panel
Log Messages Panel
Overview Panel
Processing Toolbox Panel
Results Viewer Panel

() Search QMS Panel
Spatial Bookmark Manager Panel
Statistics Panel
Temporal Contraller Panel
Tile Secale Panel
Undo/Redo Panel
Vertex Editor Panel

Toolbars
Advanced Digitizing Toolbar
Annotations Toolbar

V| Attributes Toolbar
Date Source Manager Toolbar
Database Toolbar

! Digitizing Toolbar

| Help Teolbar
Label Toolbar

! Manage Layers Toolbar

! Map Navigation Toolbar
Mesh Digitizing Toolbar

! Plugins Toolbar

/| Project Toolbar
Raster Toolbar

| Selection Toolbar
Shape Digitizing Toolbar
Snapping Toolbar
Vector Toolbar

/| Web Toolbar

Layer Order Panel
Layer Styling Panel

<

Layers Panel
Log Messages Panel
OvenviewPanel
Processing Toolbex Panel
Results Viewer Panel

@ Search QMS Panel

Spatial Bookmark Manager Panel
Statistics Panel

Temporal Controller Panel

Tile Scale Panel

Undo/Redo Panel

Vertex Editor Panel

L Panels

on top

Toolbars
at the
bottom
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@ *“Untitled Project — QGIS

0O EI"EITH:' g~ %

Ve ppRPD A o
Layers @®
v @@ TEE-F AN

1 Zoom to Layer(s)

Zoom to Selection

©2 Show in Qverview
Show Feature Count

#i Show Labels
Copy Layer
Rename Layer

] Duplicate Layer

[ Remove Layer..

7 Open Attribute Table

/ Toggle Editing
Filter...
Change Data Source...
Set Layer Scale Visibility...
Layer CRS »
Export »
Styles »
Add Layer Notes...

Project Edit View Layer Settings Plugins Vector Raster Databs

=

G Layer Properties — TOLKIEN_BRG — Ini

@ Information
18 s

¥ symbology
€@ Labels
B Masks

W 30 View

Diagrams

(]
i Fields
! Attributes Form

& Rendering

“ Temporal

Variables

e I Elevation

l‘ Metadata
MW oependencie:

Legend

- Server

B oigivng
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€—————— Read-only summary of information and metadata on the current layer

Used to define general settings for the vector layer

Provides a comprehensive tool for rendering and symbolizing vector data

Provides the capabilities to configure smart labeling on vector layers

Helps configure the current layer symbols overlay with other symbol layers or labels
Provides settings for vector layers that should be depicted in the 3D Map view tool
Allows to add a graphic overlay to a vector layer

Provides information on fields related to the layer and helps organize them

Helps set up the form to display when creating new features or querying existing one
Allows to associate features of one layer to features from another loaded vector or table
Allows to store properties for layers that are not editable

Provides the ability to perform an action based on the attributes of a feature

Helps configure fields to use for feature identification

Allows to set the scale dependent visibility and simplify geometry

Provides options to control the rendering of the layer over time

Lists all the variables available at the layer’s level

Provides options to control the layer elevation properties within a 3D map view
Provides options to create and edit a metadata report on a layer

Allows to declare data dependencies between layers

Provides advanced settings for the Layers panel and/or the print layout legend

Consists of Description, Attribution, MetadataURL, and LegendUrl sections

Gives access to options that help to ensure the quality of digitized geometries

The (Vector) Layer Properties window provides information about the vector layer
and provides general settings to manage appearance of layer features in the map
(symbology, labeling, diagrams) and interaction with the mouse (actions, map

tips, form design).
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Data Projections

() *Untitled Project — QGIS
Project Edit View Layer Settings Plugins Vector Raster Datab:

DEEERY K-8 -5
Pp Lo NRPRH QLR e

Layers @®
v e TVE-FAL

12 Zoom to Layer(s)

Zoom to Selection
2 Show in Overview
Show Feature Count
@d Show Labels
Copy Layer
Rename Layer
(] Duplicate Layer
["L Remove Layer...
~ Open Attribute Table
J/ Toggle Editing
Filter...
Change Data Source...

Set Layer Scale Visibility...

Layer CRS »
Export »
Styles »

Add Layer Notes...
Properties...
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@ Layer Properties — TOLKIEN_BRG — Source
[ | w settings

“ Layername | TOLKIEN BRG

Data sourcs encoding | UTF-8 >

= W Assigned Coordinate Reference System (CRS)
¥ symbology
EPSGi#126 - WGS 84

Changing this option

;”ﬁv

i i Rather
override the layer's CRS within this project if it could not be detected or has been incorrectly detected.

The Processing “Reproject Laye” tool should be used o reproject festures snd permansntly change = dats source’s CRS.

s

¥ Geomatry

Spatal Index Exste | Update Extents

w Provider Feature Filter

B scvon
.o
Q’ Rendering ]

FUp—

atiables | st - oK Gancel Apply

All vector/raster layers have a projection or Coordinate Reference System (CRS).
The quickest way to check projections is to right click on the layer > Properties... >

Source tab.
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Raster Layer Properties

—
@ *Untitied Project— QG Q Layer Properties - forest
Project Edit View Llayer Settings Plugins Vector Raster Database
[ a- %~ Vi : .
@ Information €———Read-only summary of information and metadata on the current layer
@, A 0 {
Ve LLAPPP L i 2
. I Source Displays basic information about the selected raster
P W
£ (i BN
L ¥ symbology Allows to control how the raster layer is rendered on map
X f i - s
L@ Transparency Provides capabilities to set the transparency level of the raster layer
£ Zoom to Layer(s) o
ind 1 (Gray) b
A g Show in Overview B Histogram Allows to view the distribution of the values in the raster
Copy Layer
" PRPTRPTTS s
Regame Layes & Rendering Allows to set scale dependent visibility and refresh layers at interval
[ Zoom to Native Resolution (100%)
" Stretch Using Current Extent “ Temporal Provides options to control the rendering of the layer over time
[T] 7oLkien._Bi T Load Raster Attribute Table from VAT.DBF
(] Duplicate Layer MR Pyramids Allows to build pyramids to improve raster performance
L Remove Layer...
Move to Bottom Elevation Provides options to control the layer elevation properties within a 3D map view
Change Data Source. S
Set Layer Scale Visibilty.. Metadata Provides options to create and edit a metadata report on a layer
Layer CRS ’
Export K Legend Provides advanced settings for the Layers panel and/or the print layout legend
Styles
Disol. 3 g 5 e =
A Layes Nes isplay Helps to configure HTML map tips to use for pixel identification
Properties. i .
i Attribute Tables Allows to convert symbology to and import an attribute table

QGIS Server Helps to configure settings of the data when published by QGIS Server

The (Raster) Layer Properties window provides information about the layer as
well as the ability to set pyramids levels, adjust appearance, and view the
histogram.
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Layout Manager

( *Untitled Project — QGIS
Edit View Layer Settings Plugins Vector Rast
New Ctrl+N

New from Template » =

Open... Ctrl+0

| Open From 'le®

Open Recent »
Close
i Save Ctrl+S
F4 Save As... Ctrl+Shift+S

Save To »

+ Layout Manager = o X

J Properties... Ctrl+Shift+P
Snapping Options...

W New from Template

Import/Export »

New Print Layout... Ctrl+P Empty Layout v Create

New Report...

B Layout Manager... -

Layouts »

Open template directory User Default % Create Print Layout X

Models » Enter a unique print layout title
(= title viill be automatically generated i left empty)
Exit QGIS Ctrl+Q

oK Cancel Help

The Layout Manager allows you to create a new map layout either from an empty
layout or a template. It can be accessed from the Project menu (Project > Layout
Manager...) or in the Print Layout window (Layout > Layout Manager...).
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Print Layout

ey ) =
Layout Edit View [tems Add Ite las Settings

1 BRLERDE B ®Rikpke @ D Y B R

@ @ G 8 ~ A O 1 (N}
PLHALNC BRLC AL E b

7 ool ¥ +
J|||.P.A..I...‘}SO....I,y.|llc-)0|..l...||l?0...l..'vP‘?o..-l..A.F?O...I.-.vp?ojl. Items Undo History
H @ 2 Items @
| ;’\, = @ - [tem
| : v r= <Picture> [}
| 2 B | O C
é N f MAP TITLE 7 e T
- Legand v $= Legend
' X wgy_wtm 90 v T] MAP TITLE
| = -5 1
| R =L i -
| & B M _Kavpoag-Ovn
Ug | =
14} ; o 0 20 @L&yout Item Properties Guides
<3 — 2
| % 3 Item Properties @
| 3
- 1
| 7| 3 Map
4 3
| s 5 w Main Properties
| 8 —
@: Update Preview
; = Y Scale 546475 L =8
| | 3
> ] Map rotation | 0.00 ® — (="
0 g- ~
8- RS Use project CRS v||®
v = V' Draw map canvas items
| 1 item selected x: 310,903 mm y: 98.3803 mm page: 1 48.7% v | 4

Print Layout interface: 1. Menu Bar; 2. Toolbar; 3. Map Layout; 4. Items and
Command History; 5. Layout Properties; 6. Item Properties

®

x
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Layout Toolbar Navigation Toolbar
BLREB L @RERKe APLPHUD
e Save project I e Zoomin
e New layout e Zoom out
e Duplicate layout e Zoom to 100%
e Layout manager e Zoom full
e Add items from template e Refresh view

e Save as template

e Add Pages...

e Print Layout

e Export asimage
e Exportas SVG...

e Export as PDF...

e Undo

e Redo
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Print Layout

> Click on the Add Map button then draw a rectangle

for where the Map Canvas will appear.
@ *Print Layout - m] X
Layout Edit View [tems Additem Atlas Settings
A A R™D ™ e T A : ] L &5

@ la (R B Remiphe i " | ' = =

( @ @ Ty ~ i relel hhb R

LPLAHALC BB L QLE bitH]

o J....F..,.l....isl:“...l.l.,|myo...|H..lléo.‘.l....Foyo‘..lHHFS.O..‘MHI.PO.Q.H Items Undo History

\_J - Items 2
i® 0__ ® @ |[ltem
y‘ = v Map 1
% | -
2 %:

Q :a. Layout = ItemProperties = Guides
[ 8- ! Item Properties @
o 1[5 Map1

73| 3 ¥ P et
in ? Update Preview

o S Scale 429806 =k

. Map rotation | 0.00 ° DK =k

:} = - CRS Use project CRS v |

2-
“; V' Draw map canvas items

1 item selected x: 291.336 mm y: 100.554 mm page: 1 48.7% xS
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Map Elements

This area keeps track of changes
Add map elements by clicking on the icons on

_ and allows you to customize map <€
the toolbar or in the Add Item menu elements.
|
Q *New - o X
Layout Edit View lte ftlas  Settings
BRRR® B (3 ® Bl lg ® i =
PLANRC BB LK LE tHE]
e i T e e o T e T e LA T
\_J 3 Items @&
He 1= Item
e 3 v - r= <Picture> [\}
u = v == <Scalebar> -
3 v 3= Legend
B | - v T) MAP TITLE
'f,\ EE v Map 1
R |3
o= Layout | ItemPropertes | Gudes
RI: Item Properties 3%
=1 &= Hap1
7:) . w Main Properties
= A Update Preview
= = Scale 546475 (=8
i' 7 Map rotation | 0.00 * S
L 3,— CRS Use project CRS
,: V| Draw map canvas items -
1 item selected x: 310,903 mm y: 98.3803 mm page: 1 48.7%

Once the map has been added, the other map elements can be added. Their

properties, as well as the page properties, can be viewed and modified. The Print
Layout tracks changes in the Undo History window.

Layout Item Properties
e Set the grid spacing and snap e Set the font
tolerance

e Set scale bar properties

e Export settings )
e Set legend properties

e Resize layout to content
[ J

Set map element properties




